1

I have done a deep research on previous post about "move label tool", but I have not found the correct answer for my case. I have the version 2.6.1 of QGIS.

  1. When I select a particular point of my layer (because I need to move the label of this point), I can activate the "move label tool", but then when i try to move the label, the label disappear. I checked the attribute table and I have seen that the name of the label became as a coordinate. Do you know what I should do?
  2. I have tried to use also the plug-in EasyCustomLabeling, but when I use it, the label appears with a white buffer, that doesn't correspond to the buffer option of the label.

Any idea?

1

I have found a solution to this issue. There is a plug-in, called "Layer to labeled layer". With this plug-in I could move label without problems. It works very well.

1

I just had a similar problem, and after searching in here, I understood what was causing the problem, and managed to solve it, thanks to the answer to another similar question (please look for question #29866).

Although your description of the problem is really short and lacks a step-by-step description of the process you made, I will assume that, when you 'activated' the 'move label tool', you followed a process like the one described in the Online Documentation, regarding Placement (of labels) for Polygon Layers, more precisely, following the steps for Using data-defined override for labelling.

But from your brief description, one point got my attention:

I checked the attribute table and (...) the name of the label became as a coordinate

Based on this, I can only suppose that, when you got to the placement part, and went for the Data Defined part (number 3), and clicked on the enter image description here icon, you did choose the field containing the name you use for labelling. This is, for me, the only logical explanation for the change you mentioned (name changed to coordinate) after you moved the label.

Personally, I think that the description of this process in the online documentation is not as detailed as it could be at that particular point: I struggled with that part myself, trying to understand how to choose the fields ‘xlabel’ for X and ‘ylabel’ for Y, when I could see no such fields as options. And then I finally realized it: those fields have to be present in the layer you are working with (which is the case for the layer they use, lakes.shp).

So I had to first create those fields on the table of my own shapefile, and only then I could use them to keep the coordinates of the labels.

But I got an extra problem (this is an extra, but as it can help others with similar problems, and it is directly related to this problem, I hope it is ok to post it here too).

I am working with a Portuguese coordinate system, with coordinates in meters. So, when creating the x and y fields, I assumed a Real number, with a length of 12, and precision of 2. But when I moved the labels to the place I wanted them, as soon as I saved the changes to the layer, the labels slightly (or not so slightly...) changed position.

After some time puzzling with this, and after finding the answer I mentioned on the beginning of this post, I checked and realized that the coordinate system of the layer I was working on was in WGS84, with degrees instead of meters. So the level of precision (2) was not enough to keep the full and detailed coordinates. So back to the table, changed the fields to a precision of 15, and problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.