7

Being in Australia I like to see the spelling of "Kilometres" used on my maps in preference to "Kilometers".

In ArcGIS Pro 1.0 I have not been able to find an option to change the text used for units and so my scale bar looks as below.

enter image description here

I have looked at the Element Properties for the Scale Bar and was hoping that setting Region and language to English (Australian) might do it but it did not.

enter image description here

Does anyone know how to set a spelling of "Kilometres" on an ArcGIS Pro scale bar?

  • Select>Ungroup>lowest level convert to graphics the text should be able to be edited. Converting map elements to graphics geonet.esri.com/thread/121347 – Mapperz Mar 3 '15 at 1:03
  • 2
    @Mapperz That should be a viable workaround but my first attempt at doing it led to my first encounter with a Serious Application Error from ArcGIS Pro 1.0. I am hoping that making this configurable rather that necessitating conversion to graphics will get serious consideration for non-US users. – PolyGeo Mar 3 '15 at 1:39
  • 1
    +1 PolyGeo. I'm so used to changing the text on the scale bar to be spelt correctly (for Au/NZ/GB) I'm surprised that this configuablity hasn't been maintained. Theoretically it's not wrong to have the American spelling, however the snide remarks that we get on the figures/maps I could do without. Ungrouping the scale bar makes it no longer 'live' so if you need to just zoom in a bit as I'm so frequently asked it would be necessary to delete the remnants of the scale bar and replace it - and if I forget.... – Michael Stimson Mar 3 '15 at 2:10
  • 1
    @MichaelMiles-Stimson I was really hoping that this ArcGIS Idea might have been implemented in ArcGIS Pro. Perhaps I placed it too low in a list I wrote up a couple of years back :-) – PolyGeo Mar 3 '15 at 2:43
  • 1
    We will use Twitter power twitter.com/mapperz/status/572834630111518720 – Mapperz Mar 3 '15 at 19:04
6

You can modify the scale bar after you've inserted it.

Remember that the Ribbon options are based on whats highlighted/clicked/active. After you've clicked the scale bar, use the SCALE BAR TOOLS > DESIGN menu to modify the label

enter image description here

-1

ESRI answered (via twitter)

Options>Units> Highlight Name and Change to the correct spelling.

enter image description here

source: https://twitter.com/Esri/status/572928068475478017

  • I had overlooked that place to change settings which looks like it should work BUT my testing so far has still failed to result in Kilometres on my maps. The INSERT | Scale Bar is sometimes failing to place scale bars at all so I'll try and simplify my tests to see if I can see it work elsewhere. – PolyGeo Mar 4 '15 at 2:16
  • 2
    I'm going to have to downvote this because I am yet to see the Distance Units (Kilometres) set in the Project Options appear in a Scale Bar element on a Layout. My test was to create a new blank project, go to Project Options and set Distance Units to Kilometre and Kilometres, Insert a new basemap, add a shapefile into that, insert a Layout and place that map on it, save my project, insert a Scale Bar that uses units Kilometers (expecting to see Kilometres once placed) but it still reads Kilometers. – PolyGeo Mar 4 '15 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.