0

I am using QGIS 2.8.1 (Wien) 64-bit

When I run it this error immediately shows up:

Algorithm Haralick Texture Extraction starting... unsupported operand type(s) for +: 'NoneType' and 'str' See log for more details

I think my orfeo toolbox error because same problem when I run another tools(pansharpening), anyone can help me?

  • ok i will try 32-bit but, my friend install QGIS 2.6 64-bit and have OTB on QGIS?? – Yax Mar 7 '15 at 10:01
1

Check if Orfeo Toolbox is indeed installed. Although the toolbox is visible from within QGIS 64 bit it might still be that the toolbox has not been installed. It could also be that the path to the install has not been properly registered.

The 64 bit version of this version of QGIS does not include the OTB binaries. Install the 32 bit version of QGIS for OTB out of the box support.

  • 1
    How to check OTB is indeed installed and install path? i only install QGIS 2.8.1 setup – Yax Mar 6 '15 at 10:48
  • 1
    It's better install QGIS 2.8.1 (Wien) 32-Bit. 64-Bit version not include Orfeo in default folder: bit.ly/1H7Phba – Jorge Santos Mar 6 '15 at 19:08
  • ok i will try 32-bit but, my friend install QGIS 2.6 64-bit and have OTB on QGIS?? – Yax Mar 7 '15 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.