2

This question already has an answer here:

I recently downloaded QGIS 2.8 and opened an existing project in it to check how it handled it and make any changes required. This project includes several raster heatmap layers.

My problem is that many of these raster layers seem to have shifted by a significant degree (but not all of them so additionally confusing). At first I thought it was a styling issue but then realised they were being displayed outside of the visible area.

They all have the same CRS set (EPSG: 27700, British National Grid), the project is set to this also.

I can see no differences between the settings for the affected raster layers and the single unaffected raster layer. Some of the affected layers are .ntf and some are .tif. The one unaffected layer is a tif.

Re-importing the layers doesn't seem to help. Creating a heatmap from scratch leads to the same problem, very odd!

marked as duplicate by Chris W, Mapperz Mar 21 '15 at 21:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    I hope for your sake you kept the previous QGIS version! You could try using the Warp (Reproject) option (Raster > Projections > Warp(Reproject)) on your rasters. I know you mentioned they were already set to your specified CRS but reprojecting them might align them correctly again. You can use the Batch Mode on a directory that only contains your rasters so you don't have to do them individually (I would advise to copy the rasters and then reproject them while the originals are safe in another directory) – Joseph Mar 6 '15 at 11:01
  • I did luckily! I wonder if this is a cunning plan to get people using the new heatmap style rather than generating tiffs. I'll give the warp a try but it'll be a pain if you have to do this to every time you generate a heatmap. – Tumbledown Mar 6 '15 at 11:07
  • 1
    Apparently it's a known bug: gis.stackexchange.com/a/137920/8891 – Tumbledown Mar 6 '15 at 14:10
  • 1
    @Joseph - Your comment is an excellent temporary solution - please add it as answer here or better in the previous queestion gis.stackexchange.com/questions/137770/… – mrz Apr 10 '15 at 12:32
  • 1
    @Joseph - thx, it is done :) – mrz Apr 10 '15 at 17:36