I can't get wine + LAStools to work in QGIS 2.8.1 (ubuntu 14.04). I only get the 22 open source functions that comes with QGIS. Outside qgis wine + LAStools works fine.

My guess is that I am not specifying the folders correctly under Processing Options -> Tools for LiDAR data, and I can't find any documentation about it. You can enter the LAStools folder and the wine folder but it is not clear how this should be done. I looked at the source code for LAStoolsUtils.py where I believe this is partly handled. I think this line is important.

folder = wine_folder + "/wine " + lastools_folder

My LAStools folder can be found at:


So I put:

[wine folder] /home/.../

[LAStools folder] /drive_c/LAStools/QGIS_toolbox/processing

I thought /.wine could be the problem but changing /wine to /.wine did not help. I also tried all kinds of variation on the directory paths but nothing worked.

Any ideas how to get this to work? There are other questions like this but for windows/MAC. E.g. Using LAStools in QGIS gives "global name 'os' is not defined"?

  • I don't think this is how Wine works... you would have to operate QGIS within WINE in order for the Windows-based application to use Windows-based files... that is to say, you can't just point QGIS on Ubuntu to the LASTools that Wine installed... Commented Mar 9, 2015 at 18:30
  • Thanks for input. So I need to run the windows version of QGIS (through wine)? But is there a "wine folder" option in the windows version? Seems odd but I havent tried the windows version. It was the wine folder option that made me think that you call wine within (ubuntu) QGIS.
    – GGeco
    Commented Mar 9, 2015 at 20:45
  • Yes, run the windows version of QGIS through Wine and you should have no problem - your outputs should be useable by Ubuntu if you write them to a folder you can access via Ubuntu... Commented Mar 9, 2015 at 20:59
  • ok thanks. I think I will do the heavy LiDAR analyses with wine + LAStools outside QGIS.
    – GGeco
    Commented Mar 10, 2015 at 7:49
  • sounds like a good plan... do report back, as I'd be interested to know how this worked and how the Wine component was implemented...! Commented Mar 10, 2015 at 14:16

2 Answers 2


This is rapidlasso, creators of LAStools. It should be possible to configure QGIS such that a call to "WinE" is automatically prepended to each LAStools call. That is the idea behind providing an option to specify a "wine folder" ... you may ask in the LAStools user forum on google groups or see the comments of this rapidlasso blog article.

The issue was finally solved. There was a bug in the processing scripts and therefore the mere presence of a path to the Wine folder did not - as intended - enable the use of Wine on non-Windows system. In the latest version of QGIS this should be fixed. For the discussion that led to finding this bug and a work-around for older QGIS versions see this thread in the LAStools user forum.

  • OK, this is good news (and in line with what I originally thought). I have posted a question on the google groups forum but no luck so far [groups.google.com/forum/#!topic/lastools/WSKtX1tbRTU]. I have also read the blog article in detail (comments too) and it does not provide much information about getting it to work in linux.
    – GGeco
    Commented Mar 13, 2015 at 13:58
  • 2
    +1 Thank you for taking the time and effort to update your answer.
    – whuber
    Commented Apr 18, 2016 at 14:15

I solved the problem here. QGIS 2.8 has a problem to get the wine folder in (line 45 of the /foo/bar/.qgis2/python/plugins/processing/algs/lidar/lastools/LAStoolsUtils.py).

Changed this line to: wine_folder = '/usr/bin' (supposing that you've already installed wine)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.