I have a client who wants to visualise cancer incidence and mortality rates by local/unitary authority across Great Britain. I've used Ordnance Survey data to get the boundaries of the authorities in GML format and saved all of them as one large GML file. I used QGIS to convert the data to KML format. I have the data in Fusion Tables now and it all looks great except for one blatant gap in the coverage.

When I look at the KML data for the missing local authority, it hasn't imported at all (ie the cell is empty). I've tried re-uploading the geometry (and re-downloading and re-converting) and Fusion Tables is definitely rejecting it as KML. I've read somewhere that Fusion Tables can mess around with your geometry somewhat, so I uploaded the KML file and pointed Google Maps directly at it and that didn't work either (I don't know how good a test that is).

I don't know that I originally created a valid GML file (I don't know the standard) but they seemed to import ok to QGIS and the final result looks great apart from this one place. The area is visible in QGIS when I load the GML file, so I don't know if QGIS is producing invalid KML, or mayble Google Maps/Fusion Tables have limitations?

I've downloaded the OS Open data pointed to by @nhopton, loaded the appropriate layer into QGIS (Layer -> Add vector layer), saved it as KML (Layer -> Save as) and uploaded it to Fusion Tables. (Note that I didn't explicitly do anything with the CRS). Generally it's worked well (and importantly the particular area that had failed with my first method worked with this, so I have the missing geometry!). However, there's a number of missing areas again. And in this case, there's much less that I've done to the data myself, so it's not so easy to assume I've just messed up the data. Any ideas why my final results look like this?

  • 1
    You could try QGIS "Check geometry validity". Maybe the polygon is invalid.
    – underdark
    Aug 22, 2011 at 12:46
  • The renfrewshire kml does have invalid geometry (checked it in FME) there seems to be many self intersecting polygons. I would check your original source.
    – Mapperz
    Aug 22, 2011 at 14:05
  • 2
    I would try the Boundary-Line data set from OS OpenData: ordnancesurvey.co.uk/opendatadownload/products.html. This provides local/unitary authority boundaries for the whole of GB in one shape file.
    – nhopton
    Aug 22, 2011 at 15:12
  • Added later: the Boundary-Line layer you will need is called "district_borough_unitary_region".
    – nhopton
    Aug 22, 2011 at 16:21
  • 2
    @andy - I think your problem is being caused by the sheer size of the of the KML file that QGIS produces. What I'd suggest you try is loading the original shapefile into QGIS and then simplifying it (Vector -> Geometry tools -> Simplify geometries) using a 'Simplify tolerance' of 12 or even greater. Try 12 to start with. Then convert the new shapefile to KML.
    – nhopton
    Aug 23, 2011 at 10:07

2 Answers 2


@andy, I was going to suggest basically the same thing @nhopton suggested. The size of the KML file may be causing an issue. Simplifying geometries may help the problem. I would suggest being careful though, as this can lower the resolution of your data. I do not think that will necessarily be an issue for your particular data set though. If you do have those concerns you can also try splinting up you data into several smaller files and make a few KML files instead of one giant one.


The problem is probably because of the Fusion Table Layer limit with multipolygon feature. I dont remember what is the limit exactly, but it something like 3-5 biggest parts of a multipolygon that can be rendered. I suggest to dissolve your table to have one feature by multipolygon part.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.