3

I'm trying to find out why I get different area figure in QGIS than in AutoCAD when I'm using the same shapefile?

What I did is I drew a shape in AutoCAD, imported it in QGIS and used the field calculator there to add area in the attribute table.

The result is that the shape's area figure in QGIS is always a little bit less than it is in AutoCAD in the properties window.

It’s the same no matter what the coordinate system is (same or different).

Could someone help me and tell me why the area figure is different in QGIS and how can I fix it?

1

I concur with @Gabriel C. above, and also believe that there may be a possibility of a scale factor issue when drawing in AutoCAD.

Unless you set a scale factor in the drawing properties in AutoCAD, the scale factor will probably default to 1.0000 which in surveying terms would give you ground distances rather than grid distances. My experience has dictated that I set a MEAN scale factor for projects when using projected or State Plane Coordinates. This can cause a problem when working in large areas since the scale factor is constantly changing. You may want to check the area derived in QGIS against the AutoCAD area by setting the Ellipsoid to None/Planimetric in the Project Properties General settings, then see if the area values are the same/similar within reason.

enter image description here

0

I assume that a projection is set in AutoCAD before drawing the shape?

It might have to do with how precise the ellipsoid parameters are. I have had some trouble at a previous workplace where data from an outside source was run through FME by a third party before getting in my hands. The process included reprojection and if I tried filling gaps with my own reprojected data in ArcGIS of the same source data, they would never align, only by a slight margin.

From what I could see, either FME or ArcGIS had an extra decimal place in ellipsoid semi-axis values and this is the only explanation I had for the (very annoying) discrepancies. There might be something similar going on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.