1

I'm trying to set up the PostGIS extensions on a Postgres 9.1 database on Debian Wheezy, but getting an error:

=# create extension postgis;
ERROR:  could not open extension control file "/usr/share/postgresql/9.1/extension/postgis.control":
No such file or directory

I am not really sure what packages I need to install on Debian to get this working. I've done:

$ sudo apt-get install python-gdal
$ sudo apt-get install postgis
$ sudo apt-get install postgresql-9.1-postgis

all of which appeared to install fine.

What am I missing?

I've tried to install related packages that I've seen on here, but with no success:

$ apt-get install postgresql-9.1-postgis-scripts
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package postgresql-9.1-postgis-scripts
E: Couldn't find any package by regex 'postgresql-9.1-postgis-scripts'

Using autocomplete, apt-get can only see postgresql-9.1-postgis. I've even tried sudo apt-get install postgis* but it hasn't made a difference.

  • This package postgresql-9.1-postgis provides Postgis 1.5. Try to install Postgis 2.0. – dmh126 Mar 13 '15 at 19:18
  • Have you found a solution? I am facing the same problem – Numenor Sep 15 '15 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.