2

I have a set of NAD83 coordinates that I need to convert to WGS84 coordinates. I am using postgis on an RDS. Specs for the box I am using from postgis_full_version():

POSTGIS="2.1.3 r12547" GEOS="3.4.2-CAPI-1.8.2 r3921" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.10.1, released 2013/08/26" LIBXML="2.9.1" LIBJSON="UNKNOWN" TOPOLOGY RASTER

I have tried a number of queries using built in functions. My latest iteration:

select st_asText(st_transform(st_setsrid(st_makepoint(-77.0282705292858, 38.9170880930097), 4269), 4326));

Result:

                 st_astext                 
-------------------------------------------
 POINT(-77.0282705292858 38.9170880930097)
(1 row)

The exact same coordinates. I have tried this with other addresses in DC (this one is for Ben's Chili Bowl) and other addresses in other states, but have always received back the exact same coordinates that were initially entered.

I would have assumed that the coordinates should be the same, but when using the online tool provided by WV (http://tagis.dep.wv.gov/convert/index.html) that uses ArcGIS on the backend, the coordinate conversion returns different results.

My assumption is that I'm missing something obvious with the query which is causing results to repeat themselves or am misunderstanding how this conversion is supposed to work.

  • 1
    Read #3 on the website. They're using Esri::108151 which is a non-time-based version of a transformation from NGS' CORS website. POSTGIS is either using nothing, or possibly EPSG::1188 which has zeroes for the parameters. – mkennedy Mar 12 '15 at 21:46
  • @mkennedy You were correct, I looked into the conversion calculation Postgis uses and there were zeroes for all parameters. Links, etc. below. – Jjensen.mike Mar 13 '15 at 20:04
1

With @mkennedy's suggestion, I looked into the conversion information available within Postgis' spatial_ref_sys. The code is available in their subversion repo at http://svn.osgeo.org/postgis/trunk/spatial_ref_sys.sql

The conversion statement was:

TOWGS84[0,0,0,0,0,0,0]

So the result of the conversion calculation was the same NAD83 values that had be entered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.