1

I have a python script that calls an ArcGIS Server geoprocessing service toolbox with arcpy.Importtoolbox. The GP service is on several separate machines behind a netscaler VIP. Each machine is it's own environment, the machines are not a part of a site. Now, when I run the python script from my local machine it runs just fine with no problems. I can publish the script as a geoprocessing service, when I try to run this process from the rest endpoint, I get an error telling me it cannot find the tool:

IOError: The toolbox file https://{netscalerURL}/arcgis/services;{folder}/{GP tool} was not found.

What I'm confused about is why the same script would work on my local machine but not as a geoprocessing service. This is not the first time I've published a script like this but it is the first time we have tried to utilize a netscaler url as opposed to a specific machine in my call.


I think I have been able to identify the problem but I still don't have a fix. The AGS machines are Linux based and run the GP service inside of Wine. Wine does not recognize the SSL certifications on the machine which results in an invalid cert and blocked access.

Is there a way to incorporate the certificate into the arcpy.importtoolbox process using the ssl module?

closed as off-topic by PolyGeo Nov 24 '16 at 7:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can I assume you're using a script like described in the arcgis help? Does it need to have the https or is it also breaking with the http (it's possible there's some connection error that the script is interpreting as a missing toolbox) – Erica Mar 15 '15 at 0:47
  • 2
    Can you take your py script and get on the AGS machine and successfully run it? That would either rule out or confirm it's a "as a service" issue. I'd recommend against having a service call a service, but I suppose in theory it could work. – KHibma Mar 15 '15 at 1:45
  • KHibma, That is a good suggestion. I will try running the script on an AGS machine to factor out a service issue. – BigLuvins Mar 15 '15 at 19:02
  • Erica, yes. That is the command I am using. However, when I reference a specific machine in the call (the method that works) it is http. This new URL is https. My server guys tell me the SSL is configured correctly but perhaps I should have them confirm that. – BigLuvins Mar 15 '15 at 19:09