1

I am using SAGA --> Grid Calculus --> Raster Calculator on QGIS version 2.6. The formula I am using is:

ifelse(gt(a,0), (a), b) 

where a is my layer with values in a greater extent than that of b. The resulting layer doesn't seem to abide by the else condition of my formula contains only 0s.

Dug into error log and found a bunch of these type errors:

ERROR 1: Can't load requested DLL: C:\PROGRA~1\QGISBR~1\bin\gdalplugins\gdal_ECW_x

  • But even re-loading gdal_ECW didn't seem to fix the issue. I am guessing this is a bug with this version of QGIS. – geo derek Mar 17 '15 at 1:54
0

Turns out you can accomplish this task easily using GDAL via OSGeo4W Shell and the following GDAL:

gdal_calc -A inn1.tif -B inn2.tif --outfile=test.tif --calc="where(A>0,A,B)"
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.