2

I followed the links from http://anitagraser.com/2012/04/06/qgis-server-on-windows7-step-by-step/ for installing the QGIS server at my Win 7 64bit system but the getcapabilities request doesn't work.

That's why I try to start the qgis_mapserv.fcgi.exe directly. It's said that many libraries are not found. I added all libraries from osgeo/bin to /osgeo/apps/qgis/bin.

Now the qgis_mapserv.fcgi.exe starts and give the output:

QFSFileEngine::open: No file name specified

  • The apache error-log doesn't show anything.
  • The getcapabilities request doesn't work and
  • I get the following error-text in the browser:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@local.domain and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I read some questions with the same problem here but in my case they doesn't work.

  • I added all librarys
  • installed the mod_fcid separately from osgeo4w

Has somebody any other ideas?

2

This sounds a lot like the problem I was having. I installed qscintilla and changed the qgis config file suggested here: QGIS Server 2.8 on Windows Server 2012

Now I'm getting something back from GetCapabilities.

  • Where is the qgis config file located? I am having the same issue but I do not seem to have a qgis.conf or a httpd_qgis.conf file anywhere in the OSGeo4W directory. – Tyler Veinot Jun 11 '17 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.