8

Has anyone been successful in building gdal with read/write support of file geodatabases? I am able to build successfully, just never see FileGDB as in the supported vector formats. Here is what I am doing:

  1. Download latest gdal trunk (example: gdalsvn-trunk-20110822.zip)
  2. Open the makegdal10.sln file in Visual Studio 2010
  3. Edit the nmake.opt file, the ONLY thing I modify at this point is the GDAL_HOME variable, the FGDB section is still commented out. Everything else left as is.
  4. Build Solution ------>SUCCESS
  5. Uncomment the FGDB Section and set path to FGDB SDK
  6. Open Visual Studio command line tools and cd to /ogr/ogrsf_frmts/filegdb
  7. Execute nmake /f makefile.vc plugin ------>SUCCESS - I now have ogr_FileGDB.dll in that folder

Now, I copy the ogr_FileGDB.dll and the FileGDBAPI.dll to the bin folder containing ogr2ogr.exe. When I run ogr2ogr --formats, I never get FileGDB as a format.

Am I missing something here?

3
  • 3
    From your description you didn't rebuild ogr2ogr with filegdb enabled. You just built the filegdb library. The two aren't linked based on the steps you describe.
    – Sean
    Aug 23 '11 at 13:02
  • You might also try the gdal-dev mailing list: lists.osgeo.org/mailman/listinfo/gdal-dev
    – neuhausr
    Aug 23 '11 at 13:57
  • I think @Sean's comment is really an answer. Sep 1 '11 at 17:04
9

You need to define the GDAL_DRIVER_PATH environnement variable to point to the path where you put ogr_FileGDB.dll. Make sure also that the filegdb sdk DLLs are accessible in the PATH or put them next to ogr_FileGDB.dll. I've updated http://trac.osgeo.org/gdal/wiki/FileGDB to be more explicit about that

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.