4

I published a mapping service on ArcGIS Server 10.3, set the layer to 'Don't show layer when zoomed' 'in beyond' to 1:577,791, prior to publishing.

enter image description here

When I bring in the mapping service into ArcMap, the layer properties is set to 'Show layer at all scales'.

enter image description here

How do I get the mapping service to automatically show up as 'Don't show layer when zoomed' into my set extent? It can manually be set, but I want to avoid that.

2

I did exactly what you say and everything is working ok; some tips:

  1. Check your layer properties: in "General" select the radio button "'don't show layer when zoomed:', and after that define the scale in the textbox: 'In beyond'; click 'OK'
  2. Check if it is working: in the standard toolbar you can put any scale you wanted and check if your last setting is working OK.
  3. Save the map with any name you wanted; all the settings will be saved. THIS IS VERY IMPORTANT
  4. Publish your service with the preferences you wanted.
  5. Check your service in ArcGIS Online (you will need an account).
  • I did everything as you mentioned. However, after publishing (ArcServer 10.3) and bringing in the mapping service in to ArcMap (10.2.2) the layer scale range is automatically set to 'Show layer at all scales'. The layer shows my 'Don't show layer when zoomed in beyond' scale of 1:577,791, but it is NOT selected. When I published my services, 'Don't shower layer when zoomed in beyond' scale of 1:577,791 was selected. – a1234 Mar 19 '15 at 14:31
0

Yes, you are right this happens Do this: 1) Open a new empty map in ArcGis; 2) After that, add your service; 3) Set the scale in 1:577,791 and note you can see the service; 4) Set the scale in 1:577,700 and note you can not see the map; Yes, "Show layer at all scales" is checked but in the practice the visual settings is the same that you saved in your service Was this informacion useful?

  • After talking to ESRI, 'Show layer at all scales' is the default setting. Currently, there is no setting via publishing or in the ArcServer manager where you can change the default of a mapping service to be set to 'Don't shower layer zoomed in beyond', so that is set appropriately when you bring it into ArcMap. – a1234 Mar 23 '15 at 22:19
0

After talking to ESRI, 'Show layer at all scales' is the default setting. Currently, there is NO setting via publishing or in the ArcServer manager where you can change the default of a mapping service to be set to 'Don't shower layer zoomed in beyond', so that is set appropriately when you bring it into ArcMap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.