0

Building some models in Model Builder for a training session, and it's not working out so well. Model Builder can't seem to find Python.

Model Builder Error 000574: Python 2.7 is not installed

Here's the kicker...Not only am I looking at Python 2.7 as I type this, but I also ran a more complex model this morning.

Since the first issue this morning I have run a repair on ArcGIS 10.2 and installed Python again, since I was still receiving the same error after the repair.

Windows 7 Data source is read from Database Connection over the network and written locally. ArcGIS 10.2 Python 2.7.9 I've used several tools and datasets in the model. Both local and netowork sources.

Error Message from Model Builder along with command line showing version

Very simple model. Verifies fine.

Python Window in ArcGIS. Commands not being recognized.

  • Does Python work within the Python window in ArcMap? – juturna Mar 19 '15 at 20:41
  • My assumption earlier today was yes. But, as of now, I see that even though the window opens, it's not actually recognizing commands. adding another screenshot to my original post... – MaryBeth Mar 19 '15 at 20:52
  • 1
    Can you open windows command line and type python, what does it do? Not the python command line, but the windows one. Start Menu --> All Programs --> Accessories --> Command Prompt. Type python and hit enter, what does it do? – ianbroad Mar 19 '15 at 20:58
  • 1
    Do you have more than one version of python installed? Is python 2.7 for ArcGis in your environment variable "PATH"? That error message will appear if it can't find python or if the version it finds is not 2.7. – Michael Stimson Mar 19 '15 at 21:53
  • Have a look at the section Paths and import in the help file here. – Hornbydd Mar 19 '15 at 22:51
1

Check to see that you have the following file:

C:\Python27\ArcGIS10.2\Lib\site-packages\desktop10.2.pth

If you don't, open notepad as administrator and add these lines:

C:\Program Files (x86)\ArcGIS\Desktop10.2\bin
C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy
C:\Program Files (x86)\ArcGIS\Desktop10.2\ArcToolbox\Scripts

saving the file like you see above.

You'll also want to check your environment variables as mentioned in the comments, but after a Python reinstall, this is the first place to start.

  • I recreated this file, just in case. No luck. When I did the change in my comments above to ArcGISx6410.2, there is a DTBGGP64.pth that points to 64-bit locations, but no desktop10.2.pth. I did attempt the 10.2 path, just to try it (changing the other to a .txt in the meantime, so there was no conflict), but there was no change. Very confused by all of this. Thanks. – MaryBeth Mar 20 '15 at 14:10
  • what happens when you import arcpy in the Python shell? – wchatx Mar 20 '15 at 15:09
  • >>> import arcpy Traceback (most recent call last): File "<stdin>", line 1, in <module> File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy_init_.py", line 21, in <module> from arcpy.geoprocessing import gp File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\geoprocessing_in it_.py", line 14, in <module> from _base import * File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\geoprocessing_bas e.py", line 14, in <module> import arcgisscripting ImportError: DLL load failed: The specified procedure could not be found. >>> – MaryBeth Mar 20 '15 at 16:12
  • It reaches the arcpy folder, but seems to have a problem with arcpy.geoprocessing. – MaryBeth Mar 20 '15 at 16:13
  • think you're bumping up against a 32vs64bit problem. did you install background geoprocessing specifically for troubleshooting this issue? if so, uninstall it and remove any path entries you made for it. – wchatx Mar 20 '15 at 17:55
1

Completely wiping everything python and ArcMap related and doing an install from scratch worked. Once ArcMap and Python were uninstalled, I went back to the python folder and deleted it (there were some remnants left behind on uninstall) and removed all PATH variables that related to either.

Cause is still unknown. My assumption is that somehow something got corrupted (yesterday morning python worked in ArcMap, but a couple of hours later it did not) and was something that was skipped when doing a repair or reinstall while I had a copy of ArcGIS already on my machine.

0

I found a solution which I hope it will work for you.

I have tried everything written in this post and python still was not working into my arcgis; giving the message 000574 error Python is not installed.

I have Win7 64 bit, and I was using Arcgis 9 then, installed Arcgis 10 and then, upgraded to 10.2 last three years, and in my last installation Python was not found by Arcgis. Also it was not working from python27.exe or pythonw.exe when I tried to run them from the folder C:\Python\Arcgis10.2.

However, I went at another computer where Arcgis 10.2 was recently installed and Python were running well. It was a Win7 32 bits but all was running fine. Then, I have checked out that python27.dll in my computer was different size (and also the creation date) than the python.dll installed in the other computer. Also, the date of the python.dll in my computer was older than the date I had installed Arcgis10.2. So, I discovered it was not replaced or updated with the last arcgis installations.

Then, I decided to remove the older python.dll file from my computer (located into System32 folder and syswow64 folder) and replace them with the newer file installed in the other computer. Also, I have pasted another copy of the new python.dll file into syswow32 just in case.

Everything started to work immediately when I opened ArcGis. I hope this could help to some of you.

0

I think that if you erase the old python.dll file from system32 and syswow64 folders, (keep a copy of these files to revert the proces just in case) and then install again python from the installation dvd, this could fix your problem. I took the python.dll file from the other computer were Argis+python were working fine, but if you don't have another computer with arcgis running, try to do what I say in the text above. References: -NOT WORKING python.dll ----->creation date 11/april/2012------->size 2918KB------> REMOVED -WELL WORKING python.dll----->creation date 10/april/2012------->size 2250KB ----->PASTED TO SYSTEM32 FOLDER

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.