2

Maybe I'm just missing the point somewhere...

I'm working on a path distance analysis, specifiying the cost layer. For this I have built a model, where I have roads and trails, both polylines, that I convert to rasters. Now I want to combine them to have one raster containing the values of the roads and the values from the trails. I am using the Raster Calculator (Map Algebra) just adding these two files (R1 + R2). Now it looks like only there the cells are added to each other where they are overlapping. In the Environments of the model I have set the NoData Raster Storage value to Maximum but it remains with a lot of empty (NoData) cells.

In former approaches I used to reclassify the raster, setting the noData values to 0 or 1 but now I have double-formatted values and the reclassifaction tool only allows me to put integer values as new values. I'm trying to avoid multiplying my raster and then deviding it again to reduce the risk of doing mistakes and to keep the values as clear as possible.

2

Try to use ead of cell statistics instead of raster calculator and use the sum operator. Also mark ignore no data. That is under the assumption that there are no "NoData" cells you wish to retain. Before running the tool, set the processing extent to UNION of both inputs under tool's environment setting.

  • 1
    Thanks, that worked great for me! Using the maximum instead of sum it even saved me a step in my model. – Nicole Mar 20 '15 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.