Out of the blue,
grass stopped functioning this morning on one of the Ubuntu 14.04 systems I use:
$ grass Starting GRASS GIS... python: can't open file '/usr/lib/grass70/gui/wxpython/gis_set.py': [Errno 2] No such file or directory Received EXIT message from GUI. GRASS is not started. Bye.
After some fussing around I found that the
grass meta-package available from the ubuntugis-unstable PPA was updated from 6.4.4 to 7.0.0 two days ago. Since I have this PPA registered in the
sources.list file the
grass meta-package got automatically upgraded. However, something went wrong, the grass-gui package is still version 6.4.4:
$ dpkg -l | grep grass ii grass 7.0.0-1~exp2~trusty all Geographic Resources Analysis Support System (GRASS GIS) ii grass-core 7.0.0-1~exp2~trusty amd64 GRASS GIS core components ii grass-doc 7.0.0-1~exp2~trusty all GRASS GIS user documentation ii grass-gui 6.4.4-1~trusty5 amd64 GRASS GIS graphical user interfaces ii libqgisgrass2.8.0 1:2.8.0+20trusty amd64 QGIS - shared grass library ii libqgisgrass2.8.1 1:2.8.1+20trusty amd64 QGIS - shared grass library ii qgis-plugin-grass 1:2.8.1+20trusty amd64 GRASS plugin for QGIS ii qgis-plugin-grass-common 1:2.8.1+20trusty all GRASS plugin for QGIS - architecture-independent data
As it happens, the new
grass-gui is marking a number of dependencies that can not be installed:
$ sudo apt-get build-dep grass-gui Reading package lists... Done Building dependency tree Reading state information... Done Picking 'grass' as source package instead of 'grass-gui' Note, selecting 'libtiff5-dev' instead of 'libtiff-dev' The following packages have unmet dependencies. libcairo2-dev : Depends: libcairo2 (= 1.13.0~20140204-0ubuntu1) but 1.13.0~20140204-0ubuntu1.1 is to be installed Depends: libcairo-gobject2 (= 1.13.0~20140204-0ubuntu1) but 1.13.0~20140204-0ubuntu1.1 is to be installed Depends: libfontconfig1-dev (>= 2.2.95) but it is not going to be installed Depends: libglib2.0-dev but it is not going to be installed libproj-dev : Depends: libproj0 (= 4.8.0-2ubuntu2) but 4.8.0-4~saucy2 is to be installed E: Build-dependencies for grass-gui could not be satisfied.
Is there any hope of getting these dependencies installed? Do I need some extra PPA for it? Or should I simply revert back to version 6.4.4?