1

I am using the interpolation plugin in QGIS to interpolate values within a boundary.

I start with two layers; 1) my points and 2) a polygon for the area of interest. Then I go to Raster>Interpolation>Interpolation and add my vector points with the corresponding attribute as an input. I use IDW (TIN does not seem to work for me), set the output file, add result to project, and hit OK.

This creates a raster but it is not the same scale as the point data. Specifically the raster is shorter and narrow (proportionally) than the point data, so the points extend beyond the edges of the raster but the values of those points are represented in the raster. It really just looks like the raster is a little smaller than it should be.

Has anyone experienced this problem? I am not sure what causes it or how to fix it.


Edit:

Interpolation plugin settings

  • 1
    Please edit your question for including an image of your interpolation plugin settings before click in OK. – xunilk Mar 23 '15 at 18:30
  • @xunilk added a screenshot – Ellis Valentiner Mar 23 '15 at 18:42
1

If your projection is in meters, you have to modifify cellsize X and cellsize Y to reasonable values (for example 30 m; not 0.00001 m). Use a raster base for these settings.

  • Thanks for your advice. Can you provide more information about how to use a raster base for this? – Ellis Valentiner Mar 23 '15 at 18:49
  • If you have, for example, a dem of your interest area you can use its parameters of resolution for cellsize X and cellsize Y and testing the aligning with the raster produced for interpolating. – xunilk Mar 23 '15 at 18:57
  • I see. Thank you. Do you know if there is a way to do this automatically? – Ellis Valentiner Mar 23 '15 at 18:58
  • Yes. You can use QgsIDWInterpolator (from qgis.analysis) in a PyQGIS script or the processing algorithms (Processing Tool Box). – xunilk Mar 23 '15 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.