0

I want to delete an ArcGIS 10.0 AGS Service and create a new one with the same name. AGS tells me that this is not possible because the Service already exists. I have however deleted the service and the msd and the AGS Cache, but it is still not allowed. What do I need to do so that I can do this?

0

If you've deleted the service from the "Services" panel in AGS and any relevant folders from the Server Dirtectories which were not deleted, you will need to re-start your instance of server.

I have previously come across this problem and seen other people post about similar problems in the past. I'm afraid I do not have the links to forum posts I have seen previously about this. But this method has worked for me.

There are 2 ways to re-start AGS.

You can re-start the machine your server instnace is on.

OR

Assuming you installed server in the default directory, if you browse to this folder

"C:\app\ESRI\ArcGIS\Server\framework\etc\scripts"

you will see a number of scripts, amongst them there is a "stopserver" and a "startserver" script.

Run the "stopserver" script and wait a few minutes. Double check that the server is down by trying to access the Server Manager page.

Then run the "startserver" script. Give it a few minutes. Check that the serevr is back up and running by trying to access the Server Manager page.

You should now be able to publish your service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.