6

What am I missing? I upgraded to ArcGIS 10.3 succesfully recompiled all other 20 or so addins after encountering a similar issue and renaming "ESRI.ArcGIS.AddIns.11.targets" to "ESRI.ArcGIS.AddIns.targets" possibly due to a known defect (#01599069)

Now I would like to create a brand new addin but I get the same warning. If if rename "ESRI.ArcGIS.AddIns.targets" back to "ESRI.ArcGIS.AddIns.11.targets" the warning dissapears and addin seems to compile but none of my old addins will recompile raising the same old error.

If i copy and paste the "ESRI.ArcGIS.AddIns.targets" and also keep the "ESRI.ArcGIS.AddIns.11.targets" both the old and new addins compile without errors or warning but the new addins ref ID are not recognized by the older upgraded addins.

I am pretty much completely confused as to what needs to be done here to make this work.

10

I did not per se figure it out becuase i don't really understand what is going on here but I was trying different things until it worked. I am not sure whether it is suppose to work or whether this crudity can even be called a workaround but here it goes:

Keep both "ESRI.ArcGIS.AddIns.targets" and "ESRI.ArcGIS.AddIns.11.targets" in the "C:\Program Files (x86)\MSBuild\Esri\" directory. (copy ESRI.ArcGIS.AddIns.11.targets paste it in the same directory and rename it to ESRI.ArcGIS.AddIns.targets)

Initially it did not work because I was trying to test it on the project i created prior the above-mention change. Well it did work in the sense that I was not getting errors when i compiled both types of addins (those upgraded to 10.3 and those newly created in 10.3) I then for some reason decided to delete the new project and start over and IT WORKED! It this therefore important to make the change in "C:\Program Files (x86)\MSBuild\Esri\" prior to creating any new addins.

EDIT: it is now August 2016 and I am migrating from 10.3.1 to 10.4.1 where the SDK requires VS 2013 or in my case 2015 Community (the free version). Targetting .Net 4.5 is now a requirement! I run into the same issue here with SOME of the Addins not creating the .addin file. Solution is pretty much the same: Copy and paste the same 2 files in the above mentioned directory and change the name from ESRI.ArcGIS.AddIns.targets to ESRI.ArcGIS.AddIns.11.targets and ESRI.ArcGIS.Server.SDK.targets to ESRI.ArcGIS.Server.SDK.11.targets respectively. Keep both the original and the renamed files in this directory!

enter image description here

  • this worked for me as well. – Jay Cummins May 1 '15 at 17:07
  • 3
    I had the same problem and after finding your post I went searching for more information and came across this KB article. It took me a while but I worked out they were talking about editing in notepad the vbproj file. – Hornbydd Aug 25 '15 at 11:44
  • The article was written after I posted this question. Does the solution work? I just installed ArcGIS 10.3 on a Windows 10 machine and had to copy and rename the target file. At least it's finally documented. – Jakub Sisak GeoGraphics Jan 28 '16 at 20:30
  • The solution in the KB article says to rename paths, but this path wasn't in my Visual Studio project, had to rename the file like @Jakub suggests and it worked. – cndnflyr Aug 19 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.