3

I have a Tablet 10.1 notes on which I installed QGIS Android (v. 2.8) and a Garmin GPS 62 stc. So I tried to do the "live GPS tracking" by connecting through the USB cable the GPS to Tablet.

Next, from the menu of QGIS I went to "GPS information" and I clicked on the "Autodiscover" but I always get the message "unable to connect to the GPS." So I tried with the other options: internal, serial device, gpsd, but always the same message.

I would be grateful if you help me understand what is wrong and if you can indicate me the steps I need to do to be able to do live tracking.

2

I'm not familiar with the 62 series, but I suspect the issue is similar to or the same as with the 60/76 series. The problem is that GPS unit can only use a specific communications protocol that is not widely supported (Garmin PVT) when connected via USB. It supports a variety of communication protocols over serial, including NMEA, but not over USB. This may differ for the 62s, because from what I can tell they don't have serial ports, just USB. However the issue is still going to be communication protocols.

The first thing to check/make sure of is that when you plug the GPS into the tablet you do not connect it as a Mass Storage Device. That allows you to access stored gpx and other files, but not the GPS receiver portion of the device.

The next thing to check is what communication protocol it is set to - NMEA, Garmin, or something else. You may be able to set the 62 to NMEA and have it work. On the 60/76, when you connect via USB it automatically goes to PVT and the Serial Data Format option where you could set a NMEA option is ignored (because it's USB, not serial). The solution is an old driver/program Garmin produced called Spanner which creates virtual serial ports to interface with the device over USB. I'm seeing references that the 62/78 series actually have a Spanner Mode option in the interface settings of the unit itself rather than needing a separate program/driver. Note you may need to update to a newer software/firmware version per that discussion thread. Another alternative to Spanner is GPSGate which is mentioned in the answer to this question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.