1

I've been using QGis for quite a few years. I normally update QGis to the latest version once it is released on qgis.org, without uninstalling previous versions. I've never encountered any problems doing this.

I recently installed 2.8.1 and it was working fine. I thought I'd fiddle with a bit of customization of QGis by way of switching off certain toolbars, menus, setting a default project to open, etc, for someone to use QGis as a simplified viewing tool for gis data. I decided to try this on one of the older versions (chugiak). It seemed to work ok while in the program, and even while restarting the program. At some point, not sure whe, possibly on a reboot, or when I tried using 2.8.1 again I got an error (screenshot attached).

Since then I've tried everything I can think of. Reinstalling, uninstalling all versions and reinstalling 2.8.1. Still didn't work. I even tried deleting the windows registry variables pertaining to QGis (I may not have done this completely correctly) and again reinstalling, yet I still get the same error.

I get the splash screen, and I can see this screen saying things like "setting up gui", "loading plugins", etc. I don't get to the tips screen and the program gui doesn't come up.

enter image description here

2

Thank you for your answer AndreJ. I also thought of opening a previously opened project, but somehow I lost the link between .qgis files and QGis. When I tried to allocate a program to it, it just didn't work.

I had a look at the registry again, as you suggested, and saw that the were more (possibly I initially missed them) "folders?" under HKEY_CURRENT_USER (see picture below). I deleted the one obviously linked to QGis customization.

That just worked just great. Up and running again. I am carrying on with the customization, little bits at a time. I made sure not to mess with the rotation field (I see it is marked experimental in the Options).

Thanks again for your answer. It definitely pushed me back on the right track.

enter image description here

Thanks Darryl

1

I faced this too, but got QGIS running when double-clicking on existing projects. It seemed to me that hiding the rotation field in the status bar caused the mess. Once it was running, I have reset all custom settings, and the error was gone.

Cleaning the registry might help, if you catch all entries. You can try deleting or renaming the .qgis2 folder, or create a new Windows user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.