2

I have an OS map on which I want to display points defined by Latitude and Longitude, but the map coo-ordinates have values I do not recognise or understand. The image shows the map, with my first point with its latitude and longitude. It is shown where I would expect it to be, but it does not appear on the map.. At the bottom of the image the co-ordinate system of the map is something I do not recognise, certainly not latitude and longitude. Please, how do I set it up so that my points are correctly displayed?

image


I am using a csv file of latitudes and longitudes, the first few lines are

Latitude,Longitude
50.82932,-1.05779
50.82934,-1.05790
50.82933,-1.05791
...

The base map is from the UK Ordnance Survey, starting at: this entry point, downloading the data for the National Grid Reference square SU, and selecting the map for su60se.

I tried to add the file of data to the map using "Add Delimited Text Layer." I did check, using Google Maps, that the first co-ordinates do represent the point shown in my image. I have set the map Co-ordinate Reference System, CRS, to WGS84. The co-ordinates in the red ellipse appear to be with reference to the top left corner of the map as 0,0 (possibly pixels?)

I should also mention that this is my first attempt to use QGIS, so please forgive my fumbling approach.

  • What format are your coordinate pairs in (csv, point shapefile)? How are you adding them to QGIS and what if any coordinate system/datum are you specifying when you do so? – Chris W Mar 31 '15 at 19:54
  • I would have thought that what I am doing is irrelevant, as the question is "How do I do it", which may mean a complete change in the way I have approached it. However I will add more information to the question. – Harry Weston Apr 1 '15 at 10:44
  • I think my previous comment is rather unkind, since what I need to do may well be dependent on the form my data is in, so I apologise for being snide and silly about it. – Harry Weston Apr 1 '15 at 13:01
  • It appears you are correctly creating the points, so my guess is the issue lies with the basemap or project CRS settings. I followed your link and took a guess at which dataset you're grabbing. It appears to be georeferenced tif, but they don't list the CRS used (unless it's National Grid, which would make sense). Each layer/dataset has a CRS, as does your QGIS project. Layers can be different if you use on-the-fly reprojection per dof1985's answer, otherwise all need to match to line up. See docs.qgis.org/2.6/en/docs/user_manual/working_with_projections/… – Chris W Apr 1 '15 at 19:38
  • Note that CRS's may use different datums, in which case not only do you have to specify which CRS you want to use (if say using a tool to permanently reproject data to a new CRS, or in QGIS this is usually done with a right-click Save As on a layer and specifying a new CRS), but you also have to specify the correct Transformation between the two datums (see bottom of link in previous comment). – Chris W Apr 1 '15 at 19:46
1

Before you do anything else, go Settings -> Options -> click the 'CRS' tab and set the default CRS to EPSG:27700 (British National Grid).

You have two problems. Firstly, from the coordinate you circled in red in your illustration it's obvious that QGIS does not recognise that your OS Street View tiles are georeferenced. To fix this, from the 'georeferencing files' directory go to the 'TFW' sub-directory and copy all of the 100 *.tfw files. Paste these into sub-directory 'su' (which is where the map images are stored).

Next, load the Street View tiles you want to use into QGIS and make sure they align properly. Then set the project CRS to EPSG:27700, enable on-the-fly coordinate transformation and save the project.

Secondly, your points layer is in lat/lon, so load it and set its CRS to EPSG:4326. QGIS should be able transform this to EPSG:27700 on the fly.

Come back if you have problems.

0

I don't understand where you get your basemap (raster) from, and why it presents those coordinates. It indeed looks like a pixels of the map and not "real" coordinates. However you might need to enable on-the-fly CRS, in order to change the coordinates displayed at the bottom. If your basemap is georeferenced to WGS84, it should not be distorted or shifted away. If it isn't georeferenced, you should consider georefrencing or getting a different base map.

An enabled on the fly CRS should like like this: OTF Enabled

To do so click on the little earth logo on the bottom right, check the enable "on the fly" crs transformation and choose, in your case WGS84.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.