5

I am trying to publish my feature service using the Boundless GeoServer. It appears that in order to have edit capabilities (I want to be able to add new points to an existing point layer tied to my PostGIS db and edit attributes in existing points if necessary), I have to use the WFS (Web Features Service) in the dashboard. I followed the instructions and set it up with transaction level capabilities connected to my workspace.

enter image description here

​However, when I go to preview the layers in GeoExplorer, I get the "transaction support not enabled" error when I use edit to create or edit. I then tried checking in Demos (as directed by this link: http://suite.opengeo.org/opengeo-docs/sysadmin/wfst/index.html) to test and see if my transaction support was enabled. It came back that for my user and password it was not enabled.

Is this somehow tied to a role or password?

enter image description here

7

You'll need to enable Transactional in the global WFS settings in the Services section of the side menu. Be careful with the workspace-specific service settings because they don't usually do what people think they do. Those settings only come into effect when you use the virtual endpoints such as http://localhost:8080/geoserver/myworkspace/wfs, but they have no effect when you are using the regular http://localhost:8080/geoserver/wfs endpoint.

You should also make sure that transactional WFS is secured so that unauthenticated users can't modify your data.

  • When you say enable in the "Global WFS Settings," are you talking about something different than the WFS under the Services tab on the left side? I tried looking in Settings>Global but I didn't see anything about WFS or setting transaction level. Thanks. – Justin Bridwell Apr 2 '15 at 1:33
  • Edited to make it a bit clearer. But yes, the Services section has global settings for each of the different services (WMS, WFS, WCS and WPS). – bosth Apr 2 '15 at 15:47
  • I was confused about what you meant when you said "global." I finally figured out that if I just didn't assign it to the specific workspace, it would work. Thanks bosth! – Justin Bridwell Apr 3 '15 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.