1

I am attempting to import an XML Workspace document (database schema) from a file geodatabase into an SDE geodatabase sitting on top of Postgres. The steps I am taking are:

  1. In ArcCatalog - right-click on the file geodatabase --> Export --> XML Workspace document (schema only). Save the XML file.
  2. Inspect the XML file to make sure it makes sense. Below on the left the ZOrigin, ZScale, MOrigin, and MScale values all make sense (either 10000 or -100000).
  3. Right-click on my SDE geodatabase connection as the schema owner --> Import --> XML Workspace document.
  4. I then repeat step 1 on the SDE geodatabase (new geodatabase with no data or schema loaded) so that I can compare the XML schemas.

The XML snippet on the right shows my SDE schema. You will notice that the ZOrigin, ZScale, MOrigin, and MScale values are all now either 0 or 1. For some reason the import process is not preserving these values. enter image description here

I have tried to simply copy and paste the schemas in ArcCatalog and ArcMap, an using the Distributed Geodatabase import tool, but with no success. When I copy or import the XML schema into a new file geodatabase it works just fine. I have also tried creating a new geodatabase user, but this doesn't produce any different results.

This should be a straight-forward export/import process. Am I missing a step or setting somewhere?

  • I take it the export is from a file or personal geodatabase feature class.. From memory the data storage isn't the same in SDE, are you using PG_Geometry or ST_Geometry storage? I think the scale/origin is not used in SDE on PostgreSQL and is just set to 1 because something has to go there. What is the value for Z domain in your Geoprocessing parameters? – Michael Stimson Apr 1 '15 at 0:10
  • @MichaelMiles-Stimson - You are correct, I am exporting the XML from a file geodatabase. I am using the ST_Geometry type. Interestingly enough, I have another Postgres database with the same setup that has the scale/origin set - I just don't know how (I wasn't the one to set that database up). – Radar Apr 1 '15 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.