3

I have approx 500 geo-referenced images that I was hoping to merge into 1 geo-referenced file, and export it as a single geotiff file. To be used in AutoCAD Civil 3D

I know I am pushing my luck and that QGIS moves. I get an error if I tried to merge all the files in 1 go. Same happens if I try building a virtual raster catelogue.

I have tried merging the files in 5 groups, by either building a virtual raster catelogue or merging the files. Then merging the 5 groups into 1 file.

However the above solutions all result in a blank image from exported (Layer -> Save As)

I have read building a pyramid may help using the .vrt file.

  • I'm assuming you need to Mosaic adjacent images (rather than merge images that may be co-incident) ? In which case you can try GDAL_Merge.py, part of GDAL. – kes Apr 1 '15 at 14:13
  • Five hundred images? How big are they? I can see that quickly getting out of hand and generating a multi-terrabyte file (and that's just output, not in memory processing). – Chris W Apr 2 '15 at 0:01
  • We have to produce HIRES aerial maps on A1 plans so yes the resolution is critical. Thus the image file will be massive. Each geo-referenced image file was 400-500KB so it would be close to a gigabyte in size. Is the merge function (Raster --> Miscellaneous --> Merge) not already incorporating the GDAL_Merge? – tfitzhardinge Apr 2 '15 at 4:58
  • KB or MB? KB seems mighty small for an image, especially 'hi-res'. MB seems more likely in which case you're not looking at a gig output (that'd be like two), you're looking at more like 250GB. How much memory is on the machine? What is the specific error you get? Is there a reason you don't just use the image tiles in CAD (especially so you can just turn on/off as needed when you're only doing an A1 area at a time - though I guess you don't mention what scale that's at)? Are you getting a blank after completion (note it may create a holding file to write to long before it's actually done). – Chris W Apr 2 '15 at 20:54
  • The images that come out of Nearmaps are that size you cannot improve the resolution above that. Hence why I wanted to create a HI-RES image from heaps of smaller images. I have now created an image which is in WGS 84 / Pseudo Mercator. However when I click save as (with the respective layer selected), even though I change the coordinates to MGA and in the save as dialog box the coordinate extents are to MGA, when I import into AutoCAD Civil 3D the insertion point is in WGS 84 system. How do I get around this. – tfitzhardinge Apr 7 '15 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.