1

Recently, the Toolbox of QGIS GRASS plugin can't find modules in my GNU/Linux Debian. When I click on any module, the toolbox reports the message: Cannot find module x.xxx and, after, I have the dialog window options totally empty (see image below).

enter image description here

My system worked nicely until yesterday.

To solve this problem (in my system recently actualized; with QGIS v. 2.8), I uninstall and install QGIS-GRASS system, including configuration files, erase my .qgis2 home and .grassrc6 (I modified my .bashrc too for adapting these changes) files. Nothing took effect.

I found out that the GRASS-QGIS modules are in /usr/share/qgis/grass/modules. My question is: How can I get my bindings to this path again?

Note: GRASS Console and GRASS commands of Processing Toolbox work well; apparently. However, I would like using the Toolbox of QGIS GRASS plugin again for saving time and it can use my already created work spaces.

  • The QGIS-GRASS-plugin still requires GRASS GIS 6 - is it installed? (A crowdfunding campaign is ongoing to fund support for G7) – markusN Apr 8 '15 at 19:20
  • Yes, it is installed and works well in GRASS Console; as I found recently (see the image). However, Modules in Modules List have disappeared. – xunilk Apr 8 '15 at 22:39
  • I've just seen a flag from you requesting that this be migrated to Unix & Linux. Unfortunately, it is too old to migrate (that must be done within 60 days of the question being asked I think) so I recommend that you delete it here, and re-word it to post it as a new question on Unix & Linux. – PolyGeo Jun 5 '15 at 9:57
0

Today (3 and half months later), I solved my problem with the update to new 2.10 (Pisa) version of QGIS.

  • Well, this is not a real solution. I suffer from the same problem, but I would like to keep 2.8 for compatibility reasons. So your original question is not answered. – Bernd V. Jul 19 '15 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.