2

I'm running a simple multiple ring buffer using ArcPy. My goal is to generate a multi ring buffer for each pond in my dataset of 50,000. Here's the line of code:

arcpy.MultipleRingBuffer_analysis(pondsNearCrop, outBufferedPonds, "356.8;792", 'Meters', 'BuffDist', 'NONE', 'OUTSIDE_ONLY')

This results in each pond getting buffered twice to a distance of 792 meters. When I run the following line of code in the Python window in ArcMap, I get the expected results-- one buffer to 356.8 meters, one from 356.8 to 792 meters.

arcpy.MultipleRingBuffer_analysis("selectedPonds_Final", "out", "356.8;792", 'Meters', 'BuffDist', 'NONE', 'OUTSIDE_ONLY')

I can't understand why this works in ArcMap but not when using ArcPy. Has anyone else experienced this?

  • Really strange. My MXD is in meters and works as expected. Not sure what datum is when I'm working in Python. Given the inputs, I'd imagine it's meters. Currently developing a workaround using multiple Buffer_analysis functions. If this fails, I may start experimenting with different datums in the script. Thanks! – Charlie Hofmann Apr 8 '15 at 18:14
  • Sorry: I deleted the comment you just replied to. I had tried your command and was getting a gap between the buffer rings. I thought I was onto something, but as I tried to track down the cause, I started getting inconsistent results and was unable to get it to fail in the same way again. – Andy Apr 8 '15 at 18:37
3

Have you tried to write the different distances in a python list : [356.8,792] as describe in the ressources : http://resources.arcgis.com/en/help/main/10.1/index.html#//00080000001p000000

  • 1
    I have-- that was my first approach after reading the documentation. Unfortunately I get the same outcome-- two buffers at 792. Thanks! – Charlie Hofmann Apr 8 '15 at 16:05
  • OK. In this case i don't get why the process fail. what the BuffDist field give as a result ? – S_TssG Apr 8 '15 at 16:12
  • The process succeeds, but all records have a BuffDist of 792-- there are no records with 356.8. – Charlie Hofmann Apr 8 '15 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.