1

I am trying to put two different maps on one sheet, one of them should show the raster image of a survey, the other one the vector-rendering of anomalies of the same area, but without the raster image.

This worked in the editor by just not updating one of the mapframes, but when I save the plan as an image QGIS automatically updates both frames, so they both show the same image.

Does anyone know, how to avoid this?

I am using QGIS 2.8.1

5

I usually lock the map I want to prevent from updating automatically, using the option 'Lock layers for map item' within map properties in QGIS composer:

  1. In the canvas: check the layer(s) you need to display
  2. In the composer: create a new map and check the option 'Lock layers for map item' in the element's properties (see screenshot below)
  3. Back in the canvas: check the layer(s) you need to display in your second map
  4. Back in the composer: create another map. The first map shouldn't follow the canvas changes.

enter image description here

Hope this will help!

  • Thanks for your fast answer. I tried this, but it didn't work. I suppose this might be a bug? I mean, it should work when I lock the maps, shouldn't it? – akra-kachi Apr 9 '15 at 11:17
  • I have updated my answer with the right option. Sorry I had not tested on my QGIS and the answer I initially gave did not do the job (not a bug, therefore...). – wiltomap Apr 9 '15 at 11:24
  • This worked. (For later readers: Just tick "Lock layers for map" to lock the map). Thanks a lot! – akra-kachi Apr 9 '15 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.