1

I've had this problem since v10.2 of ArcGIS Desktop, I recently upgraded to 10.3 and it still exists. The problem is that ArcCatalog cannot be closed normally. If I try to close it using the Windows close button (red X in Windows 7), instead of closing, all my toolbars disappear, including the menu toolbar. If I try to close it using File > Exit or by pressing Alt-F4, it crashes with the message:

ArcGIS for Desktop has encountered a serious application error and is unable to continue.

On the bright side, at least that closes the program. This problem doesn't affect ArcMap.

So if I use the Close button in ArcCatalog, I go from this:

enter image description here

To this:

enter image description here

The only way to close the program at that point is to kill the process in Task Manager or crash it using Alt-F4. Has anyone else had this problem and solved it? The only info I could find about it online concerned an issue in ArcGIS that was fixed in v10.1 SP1.

1

My suspicion is that your Normal.gxt has become corrupted and that you should consider deleting it (after making a backup copy first).

This is described in a very old Technical Article: Corrupted Normal.gxt file generates 'FATAL ERROR'.

There is useful information about this under Changing your application's appearance back to the factory settings:

Configuration changes are saved in template documents; for example, ArcMap keeps its changes in Normal.mxt. If you radically change an application and later decide you would like to reset it to its original settings, delete the application's Normal template file. Upon startup, the desktop applications will regenerate their Normal template if they are missing.

Removing your Normal template

The Normal templates—Normal.mxt (ArcMap), Normal.gxt (ArcCatalog), Normal.3dt (ArcGlobe), and Normal.sxt (ArcScene)—are located in your user settings folder. For example, in Windows 2000 or XP, the ArcMap Normal.mxt can be found in C:\Documents and Settings\\Application Data\ESRI\Desktop10.0\ArcMap\Templates, and in Windows Vista, it can be found in C:\Users\\AppData\Roaming\ESRI\Desktop10.0\ArcMap\Templates.

On my laptop the Normal.gxt is found at

C:\Users\my_username\AppData\Roaming\ESRI\Desktop10.2\ArcCatalog

which is a little odd because I have ArcGIS 10.3 for Desktop installed ... but you get the idea.

  • 1
    Thanks for the suggestion, unfortunately it didn't work. It looks like the problem may be with my Xtools extension, it's out of date and apparently can cause a similar problem. – Dan C Apr 10 '15 at 16:39
1

The problem ended up being my Xtools extension, I was using an older version and while the tools still worked with ArcGIS 10.2/10.3, it caused this problem. Updating to an ArcGIS 10.3-compatible version of the extension solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.