2

I have developed an ArcGIS Desktop AddIn for ArcGIS 10.1 using Visual Studio .Net 2010. The AddIn is established, widely used and by all accounts works well. Many folks have also been using it on ArcGIS 10.2 without issue. The one exception is that I call the AggregatePoints geoprocessing tool and this fails on 10.2 with the message:

Could not load the file or assembly 'ESRI.ArcGIS.CartographyTools, Version=10.1.0.0...

As I said, all other operations, including many geoprocessing calls, are working on ArcGIS 10.2 just fine. Before the tool runs, I check that the user is running an ArcInfo (Advanced) license.

Can someone help why this one tool/DLL is an issue on ArcGIS 10.2 please?

3
  • Do you have the option of recompiling this using the 10.2 ArcObjects SDK? Apr 14, 2015 at 12:32
  • Technically yes... but doesn't that defeat the purpose of making a 10.1 add-in forward compatible? Did the CartographyTools.dll get removed for 10.2, or this functionality move somwhere else?
    – narmaps
    Apr 14, 2015 at 16:05
  • I'm not sure why this doesn't work for you. I have a bunch of add-ins made at 10.1 and so far they all work without issue at 10.2. Here is a list of changes: resources.arcgis.com/en/help/arcobjects-net/conceptualhelp/…, though it doesn't look like your issue is on here, so I'm not sure what's going on. Apr 14, 2015 at 18:07

0

Browse other questions tagged or ask your own question.