5

I have a large Excel spreadsheet that contains lots of numeric data that I would like to import to ArcGIS 10.2 as a table using the Excel To Table (Conversion) tool.

The frustrating thing is that the numeric fields in Excel are repeatedly not recognised and are assumed as being text. I have set the cell format to numeric, cleared any possible blank cells, tried importing as CSV, removed invalid characters in the field headers. yet any possible iota of success evades me.

Does anyone know why this may be happening and/or how it can be resolved?

  • 1
    Is your Excel file .xls or .xlsx? I believe the tool, at least originally, was set up to just read .xls, although that may have changed. – recurvata Apr 14 '15 at 15:41
  • I'm pretty sure it accepts xlsx but I'll test the xls format again. – Howeitzer Apr 14 '15 at 15:49
7

If you use the Table to Table tool, which can import Excel files to geodatabase tables, you can manually set the data type of each field during the import process using the field map. Right-click the field you're having trouble with, click Properties, then change the type:

enter image description here

2

Ok so maybe I was too hasty with my angst.

I followed the CSV route found on this page and it worked fine. The frustration is still there however as to why you can't bring in an Excel sheet direct and retain the formatting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.