3

I am trying to mosaic 32 raster files (min value 0, max value 13) into one raster file so that I can later use this new raster to extract multiple values to points. However, when I try and mosaic the rasters, this error comes up:

<<Input and target dataset should have the same number of bands>>.

I am new to ArcGIS so I am not sure what this means - especially as I do not see a target dataset? Also, I am not sure what the band value should be? When I investigated the data source, it said:

Reference composite imagery are median observations from a set of quality assessed growing season observations in four spectral bands, specifically Landsat bands 3, 4, 5, and 7

Therefore logically I would assume that the band value is four? I just don't understand why this isn't working. I am using ArcMap 10.2.

enter image description here

  • 1
    Your assumption is incorrect. Note it says composite imagery, and following the rest of the sentence their source is four band Landsat imagery which they have processed/analyzed to create single-band images. And as mr.adam said, target it simply output. There are some considerations to how you think about rasters and combining them. It sounds like you have adjacent rasters you want to combine. One band in, one band out, larger area. Otherwise if they all cover the same area you'd be looking at stacking them, and each input becomes a new band in the output (as mr.adam's RGB example). – Chris W Apr 17 '15 at 18:37
  • You don't need to add bands if you have overlapping rasters, that's what the Mosaic Operator parameter is for. You can can set what value the new cell should have based on the two (or more) cells that overlap it from the original rasters. This is important to know if your rasters have collars, or something like that. – mr.adam Apr 17 '15 at 23:06
  • Thank you all. @ Chris W, they are adjacent rasters which I am trying to mosaic into one new raster with all the 0 - 13 values. I just tried to mosaic to new raster now and put the value 1 in the bands section - however the resulting mosaic was one grey blob? – Jen7 Apr 20 '15 at 9:52
  • That would probably be best asked as a separate question, but in all likelihood you need to open the properties of the result and go to the symbology tab, and change the renderer settings back to classified instead of stretched or something similar. If that doesn't do it, your new question should include a screenshot of that tab and how it's displaying. – Chris W Apr 21 '15 at 21:47
3

Here's a little background info on raster bands. Think about it like this: an RGB image would have 3 bands, one for red, one for green, and one for blue. Each raster cell would have 3 values, one for each band. The Landsat imagery has 4, because they include an extra band for infrared values as well.

In your case, there is only one band because each cell only has one value, a value from 0 to 13. To confirm this, open the properties for the raster and look in the source tab. Also, check out the symbology tab.

When the error message says "target raster" it's just referring to the output you're trying to create. You are putting in a bunch of single band rasters and expecting to get a 4-band raster.

0

It worked out that I can't re project on the fly as I am mosaicing all the raster Files. I had to first mosaic them and once that was done - only then could I re project it. Interesting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.