I have a large annotation feature class that I want to reproject from decimal degrees to a specific iteration of Albers. Using the Project tool, it appears to work, all annotation features are present in the output, attributes look fine, but the features don't draw. I can select them in the data frame, but can't see them.

What to do?

  • Have you tried the same procedure on a small subset of your large annotation feature class to see if that projects and draws OK? – PolyGeo Sep 4 '11 at 3:23
  • Yep, tried that... same result. The annotation is there, it appears to be in the right spot and the attributes are fine, just won't draw. Tried changing attributes to different colours, sizes, alignments, etc. but no dice. Adding new anno to the layer works OK - I can see that, but not the original stuff. – John Bryant Sep 4 '11 at 19:16
  • 1
    I have a very vague recollection that something was done to annotation data storage between 9.x and 10 (but could not find anything just now to confirm that). Perhaps you could try updating a copy of the geodatabase containing your unprojected feature class to 10, and then project that. – PolyGeo Sep 5 '11 at 1:00
  • It's a new file-based GDB generated in 10 with a new anno feature class I generated myself, so it's not a version issue. Still stumped! Have you successfully managed to reproject annotation in 10? – John Bryant Sep 5 '11 at 15:10
  • John, I just ran into the exact same problem; ArcGIS 10 file geodatabase re-projected an annotation layer and it does not render. The attributes look fine in the table though. Did you ever figure out a solution? I wonder if ESRI support knows about this issue? Thanks, Erik – user5985 Feb 17 '12 at 1:34

Unfortunately this is a bug in ArcGIS 10. Reference NIM060135 as the bug number for any calls to Esri Support Services.

Projecting in ArcGIS 9.3.1 is a workaround at this moment until this issue is fixed.

  • That's what I was afraid of. Too bad it's such a drag to reinstall 9.3! Thanks for answering. – John Bryant Sep 7 '11 at 22:09

open your attribute table and see if the placed flag is set to unplaced.

You don't mention the output format. I assume either personal, file or ent gdb.

If it is the placed flag then look at the default scale for the annot.
Perhaps Right click > select "zoom to resolution".

Also One of the easiest fixes might be to check the document scale of the original map and duplicate that in your new document.

  • Thanks Brad. I'm using file based GDB in ArcEditor. All the anno is "placed" according to the attribute table, editing these flags isn't having any effect. The anno feature class's reference scale is 1:50k, viewing the data at this or any other scale doesn't seem to make any difference... – John Bryant Sep 4 '11 at 20:15
  • hmm - there is not a scale dependency is there? And if you go to the default symbology for the annot, there is scale, symbol defined? – Brad Nesom Sep 5 '11 at 2:45
  • For the visible scale range, it's set to "Show layer at all scales". All the anno features are on the "default" symbol class with a defined symbology, I moved them to a new symbol class to see if that would affect anything but... nothing. The features are still there but not drawing. Weird. – John Bryant Sep 5 '11 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.