5

I am trying to use the Grass7 NVIZ algorithm from the QGIS 2.8.1 toolbox, on ubuntu 14.04.

I have enabled Grass7 in the QGIS processing preferences. I have compiled Grass7 from source, and Grass executes fine on its own. - Before this QGIS would respond with an error saying it could not find my Grass installation, however now it seems to be able to execute Grass now.

While running NVIZ the Grass console outputs the errors seen below, but runs through the entire algorithm nonetheless. When finished there is no output - the NVIZ window just closes and nothing else happens.

The errors seem to be connected to an expected version of GDAL. However the file called for (/usr/local/lib/libgdal.so.1) already exist at this location, so I am thinking it might be a an issue concerning the /etc/local/lib dir privileges, however granting read/write privileges to my user:group using chmod, has no effect. Also re-installing GDAL has been fruitless.

I am at a loss right now as to a possible solution. Maybe someone has an idea how to proceed?

Algorithm nviz7 starting...
Starting GRASS GIS... 
Executing '/home/hvitnov/.qgis2//processing/grass7_batch_job.sh' ... 
g.region: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_gproj.7.0.0.so) 
g.region: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_vector.7.0.0.so) 
v.in.ogr: /usr/local/lib/libgdal.so.1: no version information available (required by v.in.ogr) 
v.in.ogr: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_gproj.7.0.0.so) 
v.in.ogr: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_vector.7.0.0.so) 

GRASS_INFO_ERROR(29274,1): Unable to open data source 
GRASS_INFO_END(29274,1) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by r.in.gdal) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_gproj.7.0.0.so) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_vector.7.0.0.so) 

GRASS_INFO_WARNING(29275,1): Over-riding projection check 
GRASS_INFO_END(29275,1) 

GRASS_INFO_MESSAGE(29275,2): Raster map created. 
GRASS_INFO_END(29275,2) 

GRASS_INFO_MESSAGE(29275,3): r.in.gdal complete. 
GRASS_INFO_END(29275,3) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by r.in.gdal) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_gproj.7.0.0.so) 
r.in.gdal: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass70/lib/libgrass_vector.7.0.0.so) 

GRASS_INFO_WARNING(29280,1): Over-riding projection check 
GRASS_INFO_END(29280,1) 
2

Did you compile your own copy of GDAL?

If so you should remove any GDAL packages originating from Ubuntu or UbuntuGIS repos, and recompile GRASS GIS from source code to match your new libraries (be sure to run "make distclean" prior to compilation).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.