2

I have the same issue explained in this post:

How to keep georeferencing from ArcGIS when importing raster into QGIS?

But my problem is with .jpg files.

I have georeferenced with ArcGIS 10.2.2 many images with the jpg extension. ArcGIS created *.jpw, *.jpg.aux.xml, and *.jpg.ovr files.

When I load these file to QGIS the image seems to be not georeferenced, since they do not place at their exact coordinates. The coordinates show troubles too, as they are in the form of 1000, -2000.

UPDATE:

This is a non-working World File (type *.jgw):

7.0887457506922358
0.082223103086062815
0.20203539280310498
-6.8633275800653717
708475.1163774861
4748735.2214651136

This is a working World File (type *.jgw):

0.635038030525322
0.000000000000000
0.000000000000000
-0.634943151635817
711680.913345446810000
4842292.059169517800000

I tried renaming some of the World files to *.jgw (as I found that some of the World Files are in this format, and ONE of them is working), *.jpgw, *.wld, *.jpw, but none of them as worked.

Same problem comes with *.tif and *.tfwx files.

When I load the images in QGIS they are placed at coordinates 0,0 and their extents are totally erroneous, since they appear in the form of:

0
-1900
1000
0

I really don't know how to proceed now. Exporting all the images from ArcGis to other formats is a big work since I have hundreds of georeferenced images with ArcGis, but I would like to give it a try. I loaded one of the previously georeferenced raster to ArcMap and opened the "Georeferencing Toolbar": the "Rectify" button is greyed out. What should I do to "un-grey out" the button? The only way that comes to my mind is to start adding links, appending more links to the georeferenced image but I don't think that's the best solution.

  • Try deleting the .jpg.aux.xml and .jpg.ovr files, and try adding it in to QGIS. The .jpw should contain all the relevant information. If that does not work, post the contents of the .jpw file on here. – HeikkiVesanto Apr 21 '15 at 9:40
  • I tried moving only the .jpg and the .jpw to another folder, but it still doesn't work. When I load the file to QGIS it prompts me the SR is not specified and it assigns the project one. I then assign the correct SR to the jpg, but in the metadata, the coordinates origin are OK, but the layer extension is wrong. 'code' 7.0887457506922358 0.082223103086062815 0.20203539280310498 -6.8633275800653717 1708475.1163774861 4748735.2214651136 'code' this is the world file. I have the same problem with .tif and .tfwx, I've just discover that – Vale Apr 21 '15 at 10:39
  • 1
    ArcGIS adds an x to a world file when it cannot make an exact transformation. To use it just delete the x. See resources.arcgis.com/en/help/main/10.1/index.html#//…. To use the raster and world file in other software like QGIS you also have to give the raster the correct projection definition, correct being the projection used when you updated the georeferencing. If that is different from the coordinate system you are using in QGIS don't use the project's, define it before you bring it into the project. – johns Apr 21 '15 at 13:12
  • @johns: I tried deleting the x from the .tfwx file but it doesn't work. I tried loading 10 images (both jpg and tif) I have georeferenced with ArcGis and only one of them was loaded in QGIS correctly. The problem is with the layer extent in QGIS: when I load the images (the SR of the project is set as the image SR) the extent of the layer is 0; 1900; -2300; 0. It seems that QGIS doesn't read the world file in the right manner. I compared the world files with the working one but I haven't found any differences between them. I cannot figure out the problem. – Vale Apr 21 '15 at 13:59
  • I tried to bring some previously ArcGIS georeferenced jp2 rasters into QGIS 2.8 using the j2w (removing the x) and they failed to display properly. In one case ArcMap produced a bad world file which I fixed using the export world file tool but it too failed in QGIS. fGIS displayed them properly; Arcview 3x failed. Blame? To save your work you might export to another raster from ArcMap (I used tif), and if you do further georeferencing rectify the results rather than choosing to update georeferencing. – johns Apr 21 '15 at 19:56
3

I can answer my own question, because I found the solution. It is a known QGIS 2.8.1. bug that is going to be fixed with version 2.8.2. The problem is with rotational informations stored in the World File. The bug is causing the misreading of such informations. If you try to change rotational information in the World File to be zero (actually all the World Files with rotational information different from zero are having problems for me), QGIS can finally read and place the georeferenced image at their real coordinates (with obviously an error due to the lack of the rotation).

For italian speaking people, I found the answer here:

http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/QGIS-2-8-per-Win-errore-di-georeferenziazione-per-raster-con-valori-di-rotazione-diversi-da-zero-neld-td7592149.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.