0

I am trying to query features by point, so that it returns a feature that CONTAINS the point given. With the screenshot below, you can see that inspite of giving all the fields correctly, the server is returning all the features and not the ones which actually contains the given point. (I am going to use the parameters later while querying through javascript api.)

enter image description here

I have tried after selecting all the spatial relationships but same result. Same for geometry type. I am not able to understand what I am doing wrong. I know that my database uses {wkid:32637} but with spatial reference given this shouldn't be a problem.

1

i see a couple issues with your query:

  1. the geometry parameter does not expect Point coordinate values to be passed inside an array. (see doc for more info).
  2. CONTAINS in this context would mean parcels that are contained by your input query point. the more appropriate spatial operator would be INTERSECTS

you can find a working example here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.