1

I am unsuccessful in attempt to make layer with TileStache whitch gets data from MySQL. I found simple MySQL table structure (http://howto-use-mysql-spatial-ext.blogspot.com/):

create table Points ( 
name VARCHAR(20) PRIMARY KEY, 
location Point NOT NULL, 
description VARCHAR(200), 
SPATIAL INDEX(location) 
); 

and then

INSERT INTO Points (name, location) VALUES ( 'point1' , GeomFromText( ' POINT(31.5 42.2) ' ) )

For TileStache in tilestache.cfg I got:

"data":
    {
        "provider": {"name": "vector", "driver": "MySQL",
                     "parameters": {"dbname": "gis", "port": "3306", 
                     "user": "root", "password": "root",
                     "table" : "points"}}
    },

When I go to http://localhost:8080/data/ I get in console:

  • GET http://localhost:8080/data/10/167/395.png 500 (Internal Server Error);
  • GET http://localhost:8080/data/null 400 (Bad Request).

Same internal error when going to http://localhost:8080/data/0/0/0.geojson

NOTE: http://localhost:8080/osm/ works fine.

I think problem is global, because I tried making layer from .json file, but same result

closed as off-topic by PolyGeo Apr 18 '18 at 22:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

0

Why changing ports. make sure when you start tilestache-server it listens to the correct port and make sure that by going to localhost:port_of_tilestatche it shows. belows tilestache

  • I got some java program running at that port. I stopped it, but still the same errors when listening on port 8080. – user50751 Apr 22 '15 at 5:59
0

Try running tilestache on a different port. Port 8080 has many things running on it. What OS are you using tilestache-server.py -c your config file -p 9000

Then you can run localhost:9000 and you should get the

  • Port 8080 is ok. The example code "osm" works (localhost:8080/osm). But anyway tried 9000 still the same. – user50751 Apr 22 '15 at 11:22