1

I have feature class sitting in FGDB. I can add it to map, right click on it in the table of content and pick "Zoom To Layer". This is what I see:

enter image description here

I start editing session, remove most of the features in this feature class, save edits, stop editing. Right click on the layer, "Zoom To Layer". This is what I see:

enter image description here

The only option I have is to close ArcGIS session and start a new one.

Is there a better way to tell ArcGIS to use the true dataset extent?