5

I installed the OpenLayers-Plugin and set the CRS to EPSG:3857.

When I go to Web / OpenLayers plugin I get the menu with the various maps, but whatever map I choose, all the tiles are white. The layer shows up in the legend correctly, if there is another layer underneath, it is hidden by the white tiles.

When I open the OpenLayers toolbar, the small preview map is also white.

What could be the reason?

edit: The shapefile I used can be found at
www.biooffice.at/java/adscita_geryon_italy.zip

I am adding screenshots with OpenLayers active and off:

active

off

  • You might be zoomed in too far; try zooming out. You might also have a connection issue (for example if you're behind a firewall). If it's neither of these please post a screen capture. – Phil Apr 23 '15 at 15:15
  • I don't think so. I added a point laywer whith points spread out all over Italy. Hannes – Hannes K Apr 23 '15 at 15:31
  • But it could definitely be a firewall issue. What should I ask our admin to do? Open a port? – Hannes K Apr 23 '15 at 15:36
  • Can you provide your shapefile/points and a screen capture of the error? They would really help. – Phil Apr 23 '15 at 17:15
  • I've got no problem to load Google street layer with your shapefile, but I've have set CRS options to: " Automatically enable 'on the fly' reprojection...". Have you tried this option? – MickyInTheSky Apr 24 '15 at 8:44
2

This looks to me like a network connection problem.

Under Settings -> Options -> Network, you can enter proxy settings as needed for your network.

Alternatively, take the project file home and try it on your own computer.

  • 1
    thanks Andre - yes, it probably is Network/Firewall related. I tried it at home on my linux box, it works. Here at the office, behind a firewall, on Win7, it does not. – Hannes K Apr 24 '15 at 8:56
  • I guess we are on the right track. When I tell him to use the default proxy I get the following error: ` File "C:/Users/kuehtreiber/.qgis2/python/plugins\openlayers_plugin\openlayers_layer.py", line 48, in init proxy = getProxy() File "C:/Users/kuehtreiber/.qgis2/python/plugins\openlayers_plugin\tools_network.py", line 42, in getProxy proxy.setPort(settings.value("/proxyPort", 10, type=int)) TypeError: unable to convert a QVariant of type 10 to a QMetaType of type 2 ` – Hannes K Apr 24 '15 at 9:22
  • I can't help you on the proxy, because I don't have one ... – AndreJ Apr 24 '15 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.