I want to print my FME workbench to a JPG so that the entire canvas is in one image. I have tried printing it to a PDF but it is trying to put it on multiple pages. I have even tried setting the page size to A1, but the Workbench is so large, that it is still printing on multiple pages.

I'm looking for something similar to the ArcGIS ModelBuilder export as image functionality.

Am I missing something? Or is this not a feature of FME?

  • No one knows how to do this? – Fezter Apr 27 '15 at 4:21
  • Saving as an image isn't a feature of FME. There is a print option and you could install a jpeg printer driver. Whether it would still try to print it as a series of pages, I don't know. It might depend on the driver. – Mark Ireland Apr 27 '15 at 18:13
  • I just use print screen and paste into graphics editor (paint will work okay) windows 7+ has a standard 'Snipping Tool' that will capture user controlled rectangle. windows.microsoft.com/en-US/windows7/products/features/… – Mapperz Apr 29 '15 at 13:44
  • That works for small workspaces but not for very large ones. – Fezter Apr 29 '15 at 19:10
  • FME Desktop 2017 (1st March 2017, has more options to export workspaces as images) – Mapperz Feb 21 '17 at 14:43

Looks like there's an option to print to pdf, but I think pasting it to Paint is easier anyway. Let's you fiddle with the layout

  • I mentioned that I have tried pdf already. Pasting to paint or other similar software would only paste at screen resolution which won't work for large workbenches. – Fezter Aug 16 '16 at 19:10

No, not easily.

Your options are to zoom in and take a series of screenshots/snips and piece them together in an image editor or print to pdf and adjust the paper size (may be quite difficult to get right and if your workbench is just too big you may never fit it while being legible).

I believe there are some feature requests currently in the FME system but who knows if/when they will fix this.


I have been trying to acheive this for two years this is the closest I have come... It is a print to PDF solution also (sorry), but the resolution of the text and numbers of features is very high on zooming. Pls try, print>Adobe PDF>Preferences>Pages size - JIS B0! & Layout>landscape, Pages per sheet > 4, and crucially... Layout>Advanced>scaling 142%.

This will give you as much as possible in a stitched image without any work. Not exactly what you asked for, but pretty close I think?!

I hope this is helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.