6

I created a File GDB and set up a domain, and the domain was assigned to a field in a feature class. The domain behaves as expected on ArcGIS Desktop (dropdown list when editing the content of that field).

But if I zip up the FGDB and upload to ArcGIS Online to created a feature layer and edit the layer online, there is no dropdown when editing.

I don't see any additional step in this tutorial, other than a different mechanism of getting data to ArcGIS Online. I don't think I can do it the same way in ArcGIS 10.0: http://doc.arcgis.com/en/collector/android/create-maps/prepare-data-desktop.htm

Anyone has any idea what's going on?

  • Were you able to resolve this issue? I loaded a FGDB with several domains, not working. – Ian Horn Apr 14 '17 at 13:12
  • Ian, as pointed out by FelixIP originally (see below), Zip and upload doesn't work. It needs to be shared as a feature service which can be done from ArcMap. See the bottom of the link in my original post. – xyk Apr 18 '17 at 11:51
  • Have u tried to publish in arcpro? seems that is fine – yossis Jun 20 '18 at 12:52
4

Zip and upload is not going to work. As it says at the bottom of hypelink you have to share your MAP as feature service.

  • There is a checkbox to convert any eligible feature to feature service when uploading the zip. Feature service is not the problem - it's working fine for me. My issue is coded domain not automatically converting to dropdown for editing. – xyk Apr 27 '15 at 11:58
  • I tried publishing from 10.1 - the process of which is identical to what's described in the tutorial - and the dropdown showed up. Seriously they should explicitly say that dropdown won't appear unless the service is published this way. Being able to get the service up and running via uploading the zip made me think the issue was caused by something else. Thanks Felix. – xyk Apr 27 '15 at 15:46
  • I finally found a reference in the docs regarding the domain not carrying through to the Feature Service when you upload a FGDB and publish the Feature Layer from that Data file: "Domains also remain in the geodatabase, but are not accessible from the hosted feature layer." doc.arcgis.com/en/arcgis-online/share-maps/… – Adam Nov 25 '15 at 20:00
  • This couple AGOL-collector drives me nuts sometimes. This week drama was about downloading it back. Nothing documented worked, so I had to work with REST service to figure out 1 out of 9 possible combinations regarding attachments. geonet.esri.com/message/570715?et=watches.email.outcome#570715 – FelixIP Nov 25 '15 at 20:05
4

I followed the steps in an ESRI blog which shows how to add a domain through the REST API.

Direct link to the document: click me

Here's what I put to add a Yes/No domain to a field called Completed:

{
    "name": "Completed",
    "type": "esriFieldTypeString",
    "alias": "Completed",
    "sqlType": "sqlTypeOther",
    "length": 50,
    "nullable": true,
    "editable": true,
    "domain": {
        "type": "codedValue",
        "name": "Completed",
        "codedValues": [
            {
                "name": "Yes",
                "code": "Yes"
            },
            {
                "name": "No",
                "code": "No"
            }
        ]
    },
    "defaultValue": null
}

I tested it out in the Collector app, and it works great.

There is a gotcha though. You need to change the “lastEditDate” line to be empty quotes or it throws an error when you hit the Update Layer Definition button.

So put:

“lastEditDate” : “”

And it should submit successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.