1

I would like to put the year in the slider text and for the data to be scrolled through via year.

data looks like this

Apparently it was working until three weeks ago, and now doesn't. In particular the slider now shows wonky month/day combos rather than just the year. Just the year is what is desired.

How might I fix this?

Initially I fixed the really wonky dates by fixing the -torque-frame-count in the css from default 256 to 227 (for years 1787-2014), which is the number of years. But now, instead of getting random dates, it tends to flip between Jan 1 and Dec 31 on both sides of the date range. It seems disproportionately difficult to find information to get this done - surely this is a common request?

enter image description here enter image description here

  • I have just tried to improve on this solution by doing a new select, but the value returned is a number not a date. This causes the slider to start at 0 rather than at 1747. SELECT cartodb_id,the_geom,context_for_making_constitution, first, key_provisions, lat, lon, location_vis, region, state, the_geom_webmercator, EXTRACT(YEAR from year2) as date_part, years_constitutions_made FROM with_latlons_years – datakid Apr 29 '15 at 2:46
  • When I read the postgreSQL docs on date, I tried changing the EXTRACT - which returns a double - to date_trunc which returns a datestamp, but that's returning 1893-01-01T00:00:00Z rather than 1893. – datakid Apr 29 '15 at 2:52
1

We did some changes on the intervals of Torque.

Yesterday we did a fix for this: if the data range is bigger than one year, then it'll show as always. I think this fix will solve your issue, as I'm seeing that you're using different years as the date.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.