1

In arc gis for server 10.2 I have deleted some map services. But in the server logs it shows the following messages regularly even though the services are not in use anymore. I deleted the services through server manager

SEVERE

29 Apr 2015 13:25:08

Unable to process request. Service (service name would be here) not found

Rest

WARNING

29 Apr 2015 13:25:08

Error getting service.

Rest

Could anyone suggest why it may be logging these errors regularly?

  • Just curious, was this a cached map service? – a1234 Apr 29 '15 at 13:20
  • I'm afraid it wasn't a cached map service – tommo Apr 29 '15 at 13:47
1

Is some application trying to access the deleted service? For example: if I try calling a deleted map service I get the following logs:

enter image description here

  • I've checked to see if any applications are trying to access the services like you mention above. From what I can tell there are no applications that should be using these services anymore. Before I deleted the services I made sure that all applications that were using them were removed. Sometimes the errors keeping repeating for a long time then stop then start again. Is there anything else that could be calling these services besides applications? For example a process within ArcGIS for server. – tommo Apr 30 '15 at 7:02
  • 1
    If you haven't already, you could turn on the other Logs columns like machine, code, user name you might be able to drill down on it...For instance, I just typed a deleted service into a browser and the machine column identified me... If it is some stray service in an app I think it would bring back that app in the username columnn, etc.. And also set log filter to Verbose – CCantey Apr 30 '15 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.