1

I am using OpenLayers in Drupal to display Geoserver WMS data. I can get the layer to overly properly, however the raster layer (png) has a white background I cannot remove. I have created a style in Geoserver using: ... FeatureTypeStyle - Rule - RasterSymbolizer - ColorMap - ColorMapEntry

However, even though this style is referenced in the 'Styles' for the OpenLayers layer in Drupal, nothing I do to this style file makes any changes to the map. ie: the background is always white. I have also tried to use opacity to make the entire layer transparent, but nothing changes. Drupal does not seem to be applying the style to the layer.

I am not sure if it matters, but the Geoserver information is provided by an external WMS server: http://nowcoast.noaa.gov/wms/com.esri.wms.Esrimap/obs?service=wms&version=1.1.1&request=GetCapabilities

Has anybody had this problem and found the proper fix?

  • I had a similar problem but mine is not raster but polygon. The image should look something like this: !enter image description here but it looks like this on GeoServer: !enter image description here But when i change the S3_B0_I1e_ column in attribute table from 0 to 1, it works fine. Did you solve the problem yet? – munmunbb Jul 1 '15 at 5:42
  • You say you are using GeoServer but your link is to an ESRI ArcIMS WMS service (not GeoServer). – nmtoken Jan 25 '16 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.