1

I have downloaded trial version of FME 2015 and I try to read an Excel file which included multiple sheets with filtered columns and pivot tables. I want to read this file in FME and write the data into a Postgres database.

When I use the Excel Reader to preview the file in FME I see that the columns with the non-latin characters are replaced with question marks. How can I set the encode type in the reader? Should I do it before I load the file to FME? I have already tried to save the excel file with a different encode type but still the problem occurs. Any suggestions?

  • 1
    you might be better off have the files as txt or csv with utf8 or utf16 to get your not latin characters through. – Mapperz May 5 '15 at 13:32
  • I will try this. – user1919 May 5 '15 at 13:34
  • 1
    The question is, where are you seeing those question marks? Is it in Postgres? If so, it might be the Postgres writing that is the issue. Regardless, I'll try and get an FME support person to investigate and answer this question for you. – Mark Ireland May 6 '15 at 14:18
  • 1
    Could you please send your excel file to support@safe.com (attention to Candace). Do you know what your system locale setting is? If not, what region are you in? Also, do you know the language of the excel file? Thanks, Candace Low Safe Software Support – user51684 May 6 '15 at 19:12
  • I am sorry but I can not send the file as it is confidential. The language in the file is greek and the system locale setting is set to English. Should I change it? – user1919 May 7 '15 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.