0

I am trying to Test a WMS by adding in QGIS as per http://anitagraser.com/2012/04/06/qgis-server-on-windows7-step-by-step/

If I follow the steps, QGIS cannot find the server.

When I take a look at the printscreen above, I see that there is QGIS.exe in the c://OSGeo4w/apps/qgis/bin –map.

Is this necessary? When does this get done?

  • Welcome to GIS SE! As a new user be sure to take the Tour. I've edited your question to try and make what you are asking clearer. In particular you seemed to be addressing your questions to the author of that tutorial but your answer(s) may come from anyone familiar with it and WMS from QGIS Server so I redirected them to all potential answerers. – PolyGeo May 6 '15 at 7:51
1

If you installed the packages correctly you now need to decide what web server you want to use for your QGIS server. Windows has its own IIS, but I'm guessing you're using the provided apache. First of all you need to theck if that qgis_mapserv.fcgi.exe is even working (the .exe file is used to respond to your requests). You can simply go to that folder hold shift and right click to open command window. In the command window just tpye qgis_m and press tab, it should finish off your filename and press enter to run the exe. If everything mostly works, you should get some warnings. But if you get a error that you have a dll missing, you have to copy them from the c://OSGeo4w/apache/bin folder to the c://OSGeo4w/apps/qgis/bin –map. Like Anita mentioned in her tutorial these 2 files are missing libeay32.dll and ssleay32.dll. After you copied these 2 files try running the .exe in your cmd. If you only get warnings about ECW and JP2ECW then you're good to go, if you still get .dll errors find the appropriate ones in c://OSGeo4w/apache/bin.

Once your qgis_mapserv.fcgi.exe works you can move on to setting your apache server. All you have to do in c:/osgeo4w/apache/conf/httpd.conf is change

Listen @apache_port_number@

to our needs, e.g. to listen on port 80

Listen 80

After this restart apache and try a simple url to see if your server is up and running http://localhost/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

If this works you can continue on working with Anitas tutorial.

If you want to use IIS, leave a comment below and I'll write how to set it up in that web server.

  • I would love to know how to set QGIS Server up to work with windows IIS instead of Apache – Dayne Feb 10 '16 at 12:43
  • It would be easyer if you explain where you get stuck, instead of me writing the whole process. The process is quite similar except at the part where you'll need to add these new modules cgi and fcgi. You'll also need to set up these IIS modules to be executed when a map is called. I managed to get the basic qgis web server up and running but never continued with setup for webclient. – Piskr Mar 14 '16 at 7:10

protected by underdark Mar 12 '16 at 16:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.