I've joined a csv file of values (0-100) (created in Excel), with local authority boundaries for the UK in ArcMap 10.1. I want to display the percentage of these areas not receiving 3G mobile coverage.

I've gone into properties and then selected quantities. I've selected the data I want to display and it displays huge values which are not in either the original data set or in the attributes table. Why is this? Here is a screen shot (note the range):

Screen grab 1

When I go into the attributes table for the selected variable ('t') and then sort descending, the largest value is 99. Why does it think there are values up to 1965621253?

Screen grab 2

I've not managed to find an answer online but so far I've:

  1. Checked that Excel isn't adding on extra values (I copied and pasted just the values numerous times)
  2. Generated a new csv file
  3. Tried to join the data numerous times to see if this made a difference.
  • 1
    Have you tried restarting Arcmap and do it all over again? Also, what if you look at the csv table from within Armap/catalog? It's not a decimal separator mixup?
    – Martin
    May 7, 2015 at 11:59
  • 2
    I have found that joined tables sometimes confuse ArcMap, as will null values. Workarounds include removing and redoing the join, doing the join in a new project and symbolizing it there before adding that to the original project, and exporting to a new feature class for symbolizing.
    – John
    May 7, 2015 at 12:52
  • I would try adding a field and calculating it to equal "t". Then, remove the join and try to symbolize it off of the new field. Like @johns said, joined tables behave strangely sometimes.
    – GeoJohn
    May 7, 2015 at 13:53
  • I tried restarting Arcmap - same problem. I checked that there are no null values in the data set. I tried making a new project and repeating the join - same problem. I exported the shape files and did the join again - same problem. I finally tried to make a new field equal to the field I'm trying to symbolise. Still the same problem I'm afraid. Any other ideas? May 7, 2015 at 17:00
  • What is the data type of the t field in ArcMap? Both as part of a Join and if you export the join result to a separate file? Is there any kind of numeric formatting on the field that might be disguising the true values? In attribute table right-click field heading and you can find the answer to both of these - it will tell you the type and you can click the ... numeric button to check that. Can you post files (or excerpts)/sources so we can try to duplicate?
    – Chris W
    May 7, 2015 at 22:54

1 Answer 1


The classes seem to contain the values you want to display but have also ultra high ones. I have not a exact solution to your problem but some hints you could try.

  • Add the .csv file to ArcMap and export it as .dbf before joining. Add the .dbf to your workspace and try the join with this file
  • Alternatively open the .dbf files in excel and check if these high values occur in the table.
  • There could be a problem with the delimiter as well. As far as I know the standard delimiter of excel is different to the one of ArcMap. You could try to replace these delimiters with Notepad++ or similar before adding the .csv to ArcMap
  • 1
    Also try putting importing the CSV into a .gdb table. I find ArcMap works super well with these tables, so I use them a lot when I don't need to view or change them with other software. Also, it's improved, but Excel + ArcMap + joins is sometimes a little much to ask...
    – mr.adam
    May 7, 2015 at 18:53
  • Having opened the file in Notepad I found a null value that I hadn't seen in Excel. The join then worked fine and the problem was solved. Thanks for the help. May 8, 2015 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.