1

I have a model I built to select and delete features, I built it so I can run it quick on multiple feature classes.

Works fine in ArcMap 10.3 but when I use it in ArcCatalog I get the error "Value Cannot Be Feature Class Raster or Mosaic Inputs Required."

My model has Select by Attribute and Delete Features with a Stop Function so it will stop if there is no selection.

Model Parameter for the Select By Attribute is set to Feature Class, have tried Feature Layer also.

I get the same results from each, it runs in ArcMap but Raster Error in ArcCatalog.

Any suggestions as to what might be going on?

  • 1
    I have come across instances before where a tool in Model Builder will error telling me that the input is not a raster, when that tool would not want a raster as an input. There seems to be a bug somewhere, but I've never been able to consistently replicate it. Have you tried deleting that specific tool from the model and re-adding it? Or recreating the whole model into a new model? Otherwise Duncan's answer below seems like a good thing to try. – Dan_h_b May 8 '15 at 12:37
5

Sounds like the original model was developed in ArcMap. If you look at the syntax section of the help for the Select Layer By Attribute tool it explicitly states the data type of the input layer to be a feature layer or table view. If you are running your model from ArcCatalog and navigating to the dataset in the folder then you are accessing the source data which is a Feature Class. The tool takes as input a table view or layer object. So if your intention is to run this model only in ArcCatalog then it is likely that you need to place a Make Feature Layer tool on your model, expose that as the parameter and have that feed into select by attribute tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.