13

I'm sure there is a really simple explanation to this but haven't found any pointers on this forum or elsewhere. I seem to have lost the 'Processing' menu from QGIS and can't figure out how/why!?

Any ideas what I might have done to make this happen?

I'm running QGIS 2.8 built against GDAL 1.10 on Ubuntu 14.04.

enter image description here

1
  • I am having this problem as well. The processing toolbox is installed in the plug-in manager but I cannot find it anywhere. HELP And i cannot edit or uninstall/reinstall processing toolbox plug-in--it's locked. Apr 29, 2018 at 13:28

3 Answers 3

25

The Processing menu is tied to the Processing plugin. So please check if you have deactivated the Processing plugin in the Plugin Manager.

enter image description here

3
  • To enable it, go to Plugins -> Manage and Install Plugins... -> Installed and check the checkbox next to "Processing". PS. I didn't deactivate it for sure, it must just happen.
    – Line
    Mar 6, 2018 at 11:55
  • mine shows ModuleNotFoundError: No module named 'psycopg2' error when I'm trying to reload Processing or during startup. Processing toolbar isn't visible because of it. any idea? Jan 2, 2020 at 6:24
  • This should really be on by default.
    – GeorgeC
    Dec 1, 2021 at 10:16
3

Processing sometimes crashes or takes a long time to load. so sometimes QGIS disables it. As @underdark answered, re-enable it from plugins menu.

1
  • 1
    Working with QGIS 3.4.9, Processing was checked in the Plugins but not appearing on the menu bar. Unchecking and then checking the box again helped it reappear.
    – Richard D
    Aug 29, 2019 at 3:27
1

On Fedora (and possibly other GNU Linux distributions) QGIS is split into multiple packages. Run:

dnf search qgis

and then install any packages that seem relevant. On other distributions replace dnf with the name of your package manager e.g. apt. Installing python3-qgis and qgis-grass did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.